8MM FORUM WORLDWIDE • View topic - SANKYO 700 SOUND SUPER 8 QUESTION

8MM-16MM FORUM WORLDWIDE

The International Forum for 8mm, 16mm, and 9.5mm film
Dedicated To Collectors Around The World
It is currently Thu Sep 21, 2017 6:33 am

All times are UTC - 5 hours [ DST ]

Click on any of the boxes below to link to a new page



Screening Rooms    Ebay Film Sellers    Film/Equipment Sellers    Laurel and Hardy    Magnetic Striping


Our mission is to provide a "free" forum for all members. This forum will not delete, lock up, or edit any posts. On this forum, you are "free" to question any statement that is not understood, and debate any differences you have with another member. We only moderate when a member will not back up his accusations. There are no condescending attitudes from the Administrator or the Moderator. You will be treated with respect. Dan Lail, Admin. and Chris Smith, Moderator



Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: SANKYO 700 SOUND SUPER 8 QUESTION
PostPosted: Mon Jun 12, 2017 11:53 pm 
Offline
Film Expert

Joined: Thu Sep 01, 2016 12:38 am
Posts: 24
Location: massachusetts
hello everyone, just wanted to say my projector is up an running. i had a split motor belt. just recieved new one in today and unit ran fine. but one question, when it came to rewind was slow not as fast when i was running films a while back. i noticed when i was winding the film back onto reel several times it felt very tight. any one with any remedies? thnx


Top
 Profile Send private message  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group